Errors in Tasks - (version of * not compatible with this version of the DataFlow.) during Validation

Jul 2, 2014 at 2:34 PM
Took a while to work out how to connect to the catalog on my server for testing the package on the server, but I got it...

Package Path = Package.dtsx
Project Path = ProjectName\FolderName '****(no preceding "\" no SSIDB)
Server = ServerName
StorageType = SsisCatalog


Now the package won't validate due to version differences in the LookUp Tasks.

Task Error: The version of LKP EXISTING RECORDS is not compatible with this version of the DataFlow.

and connections not found:

Task Error: The connection "{6EA46583-95C9-429C-80BB-39EADFE81239}" is not found. This error is thrown by Connections collection when the specific connection element is not found.

Task Error: Connection manager "{6EA46583-95C9-429C-80BB-39EADFE81239}" does not exist.

(The connections are stored at the Project Level in this project and shared between the Packages)

Do I need to download the code and compile on my machine to match the release levels?

(VS 2012 Version 11.0.61030.00 Update 4)
(SSIS Version 11.0.3360.12)